Phone System Issue (continued)
Incident Report for Seven Corners
Resolved
This incident has been resolved and our phone system is fully back online. Thank you again for your patience and understanding.
Posted Nov 07, 2019 - 16:38 EST
Identified
Our phone system provider is continuing to have intermittent issues that are affecting our phones. They have identified the problem and are working to resolve it completely. We encourage our customers to use the chat functionality on our website. Thank you again for your patience.
Posted Nov 07, 2019 - 14:57 EST
This incident affected: Phone System.