Payment Processing
Incident Report for Seven Corners
Resolved
This incident has been resolved. . Thank you for your patience!
Posted Aug 04, 2022 - 18:36 EDT
Identified
We are currently experiencing an issue with one of our payment processors that is preventing us from taking payments for some of our products. We have identified the issue and are working diligently to resolve the problem. We will provide updates as we receive them. Thank you for your patience!
Posted Aug 04, 2022 - 17:42 EDT
This incident affected: www.sevencorners.com.