Phone System Issue
Incident Report for Seven Corners
Resolved
The issue with our phone system has been resolved by our provider. Thank you for your patience!
Posted Nov 07, 2019 - 13:32 EST
Identified
Our phone service provider is currently experiencing an issue that is affecting our phones. They have identified the issue and are working to resolve it completely. We encourage our customers to use the chat functionality on our website if they are experiencing long wait times on hold or are getting disconnected from our phone system. Thank you for your patience.
Posted Nov 07, 2019 - 13:09 EST
This incident affected: Phone System.