"Chat with an Expert" Issue
Incident Report for Seven Corners
Resolved
This incident has been resolved. Thank you for your patience as we worked to get our chat service back up and working again.
Posted Nov 12, 2021 - 08:57 EST
Investigating
We are currently investigating an issue with our online chat service on our website. Thank you for your patience as we work to resolve the issue.

If you are experiencing an issue with our chat service, please refer to our Contact page for another method to communicate with any of our teams: https://www.sevencorners.com/about/contact
Posted Nov 03, 2021 - 22:14 EDT
This incident affected: Live Chat.