Phone system performance degradation
Incident Report for Seven Corners
Resolved
This incident has been resolved. Our phone system has returned to normal operation. Thank you again for your patience.
Posted Aug 30, 2020 - 11:26 EDT
Identified
Our phone system service provider is currently experiencing issues with their downstream ISP, which is affecting Seven Corners' ability to answer some phone calls. Please use the Chat functionality on our main website if you are having problems calling us. We will keep you updated with any new updates we receive. Thanks for your patience.
Posted Aug 30, 2020 - 09:44 EDT
This incident affected: Phone System.