Phone System Outage
Incident Report for Seven Corners
Resolved
This incident has been resolved. Thanks for your patience.
Posted Jan 15, 2022 - 16:02 EST
Investigating
We are currently experiencing an issue with our phone lines. Please contact us using any of the other methods listed on our contact page below, including chat, email, texting, and WhatsApp:

https://www.sevencorners.com/about/contact
Posted Jan 15, 2022 - 15:52 EST
This incident affected: Phone System.