Service Degradation - Credit Card Purchasing on Site
Incident Report for Seven Corners
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 16:51 EDT
Identified
We are working with our third party credit card processors to fix a problem with credit card purchasing on our site.
Posted Oct 07, 2024 - 16:17 EDT
This incident affected: Purchases.