Purchasing from sevencorners.com
Incident Report for Seven Corners
Resolved
This incident has been resolved. Thank you for your patience as we worked through this issue.
Posted 2 months ago. Jul 11, 2019 - 11:41 EDT
Identified
We are currently experiencing an issue on our website where customers are not able to navigate to one of our Travel Insurance Plan pages. We have identified the issue and are working on a fix. We are sorry for any inconvenience this has caused.
Posted 2 months ago. Jul 11, 2019 - 10:43 EDT
This incident affected: www.sevencorners.com.