Phone System
Incident Report for Seven Corners
Resolved
This issue has been resolved and our phone lines are back up and working. We are sorry for any inconvenience this has caused.
Posted 6 months ago. Aug 25, 2018 - 22:51 EDT
Investigating
We are currently investigating an issue with our phone system. Our 800 numbers are not working as expected, so we ask you to call the local numbers when trying to contact us.
Posted 6 months ago. Aug 25, 2018 - 19:50 EDT
This incident affected: Phone System.