Payment processing
Incident Report for Seven Corners
Resolved
This incident has been resolved. We will continue to monitor the situation, but at this time we believe that all systems are operational.
Posted Jul 13, 2018 - 09:55 EDT
Update
Our external vendor has corrected their issue. We will continue to monitor the situation, but at this time we believe that all systems are operational.
Posted Jul 13, 2018 - 09:55 EDT
Monitoring
We are currently experiencing an issue with processing credit card payments on our website due to a problem with our external vendor that processes payments. We are monitoring the situation and will send updates when we know more information.
Posted Jul 13, 2018 - 08:59 EDT
This incident affected: www.sevencorners.com.