Website Purchasing Outage
Incident Report for Seven Corners
Resolved
This is resolved now.
Posted Aug 04, 2018 - 01:23 EDT
Identified
The issue has possibly been identified and we are working to test the solution. Thank you for your patience.
Posted Aug 03, 2018 - 23:22 EDT
Investigating
We are currently having an issue with credit card purchases of products from our website. We are investigating the matter and will update you as soon as we know more.
Posted Aug 03, 2018 - 22:19 EDT
This incident affected: www.sevencorners.com.