Payment processor and purchasing
Incident Report for Seven Corners
Resolved
The credit card processing issue has been resolved with our payment processor. Thank you for your patience.
Posted 2 months ago. May 17, 2019 - 15:10 EDT
Investigating
We are currently investigating an issue with one of our payment processors not allowing credit card payments. This is not affecting all of our policies. We are sorry for the inconvenience and will update you when we have more details.
Posted 2 months ago. May 17, 2019 - 14:47 EDT
This incident affected: www.sevencorners.com.