Phone Line Issues
Incident Report for Seven Corners
Resolved
This incident has been resolved. All phone lines are working as expected at this time.
Posted 12 months ago. Sep 03, 2018 - 20:28 EDT
Update
We are continuing to investigate this issue.
Posted 12 months ago. Sep 03, 2018 - 19:30 EDT
Investigating
We are currently investigating an issue with certain toll free and local phone lines. Customers with questions regarding policies can call our main Customer Service number at 1-800-335-0611. We apologize for the inconvenience.
Posted 12 months ago. Sep 03, 2018 - 19:01 EDT
This incident affected: Phone System.