ID Cards and Coverage Letters unavailable
Incident Report for Seven Corners
Resolved
ID Cards and Coverage Letters are now available for all members. Anyone that was affected by this outage should have received an email with new links for downloading the files. Please contact our Customer Service (https://www.sevencorners.com/help/contact) if you are experiencing any issues with downloading these items. Thank you again for your patience.
Posted 9 months ago. Jan 12, 2018 - 11:42 EST
Monitoring
ID Cards and Coverage Letters are now available for download for most users. However, there is still a very limited number of customers who will still need to contact us if unable to obtain copies. Please contact our Customer Service (https://www.sevencorners.com/help/contact) if you are unable to download a copy of your ID Card or Coverage Letter.
Posted 10 months ago. Jan 01, 2018 - 12:47 EST
Investigating
Update: We are still working to resolve issues from the outage we experienced recently and need to continue not allowing access to online ID Cards and Coverage Letters. Please contact our Customer Service (https://www.sevencorners.com/help/contact) if you need a copy of your ID Card or Coverage Letter. We expect to have this service restored within the next 24-48 hours. We apologize for any inconvenience this has caused.
Posted 10 months ago. Dec 28, 2017 - 09:23 EST
Identified
As we are working to recover from the outage that we experienced over the past 24 hours, we will be taking away the ability to access online ID Cards and Coverage Letters. Please contact our Customer Service (https://www.sevencorners.com/help/contact) if you need a copy of your ID Card or Coverage Letter. We are sorry for this inconvenience, and we will let you know when this service is restored.
Posted 10 months ago. Dec 27, 2017 - 13:29 EST