Roundtrip for U.S. Residents Product
Incident Report for Seven Corners
Resolved
This issue has been resolved. We are sorry for any inconvenience this has caused.
Posted 3 months ago. Apr 24, 2019 - 16:06 EDT
Identified
We are currently experiencing an issue with our Roundtrip Plans for U.S. Residents product. We are actively working on a resolution and will post an update when we know when the problem will be fully resolved. Thank you for your patience.
Posted 3 months ago. Apr 24, 2019 - 15:26 EDT
This incident affected: API.