800 number outage
Incident Report for Seven Corners
Resolved
This issue has been resolved. All phones lines are now working as expected.
Posted 12 months ago. Sep 03, 2018 - 00:33 EDT
Identified
We are currently having an issue with many of our 800 phone numbers. If you need to contact Seven Corners, please call the local or collect phone number for the service that you are needing. We have identified the issue, and expect a resolution soon.
Posted 12 months ago. Sep 02, 2018 - 23:58 EDT
This incident affected: Phone System.