Website purchasing outage
Incident Report for Seven Corners
Resolved
Our website is now fully functional and purchasing is back online. Thank you for your patience!
Posted 8 months ago. Dec 27, 2017 - 04:41 EST
Investigating
Our site is currently not able to process credit cards for purchases at this time. We are working to resolve the issue and will provide updates as soon as we can. Purchasing may not be available for up to an hour.
Posted 8 months ago. Dec 26, 2017 - 21:12 EST